[Vserver] Problems with libusb in vservers

From: Ludovic RESLINGER <lr_at_cuivres.net>
Date: Mon 09 Oct 2006 - 19:51:30 BST
Message-ID: <20061009185130.GC17955@bach>


I have a problem to use USB scanner using
libusb in vserver.
It seems impossible to access to /proc/bus/usb/*
in vserver.
I modified the /usr/lib/util-vserver/defaults/vprocunhide-files
to add /proc/bus, but there is only /proc/bus/input and /proc/bus/pci.

I added the line to fstap to mount /proc/bus/usb but it changed nothing.

When I specify /proc/bus/usb in vprocunhide-files, I meet this error
when I try to reload vprocunhide:

Fixing /proc entries visibility.../proc/bus/usb/: Invalid argument
/proc/bus/usb/devices: Invalid argument
/proc/bus/usb/005: Invalid argument
/proc/bus/usb/005/001: Invalid argument

My host system is a debian stable on powerpc, but the problem
is the same with i386.
I use the latest stable vserver-patch with linux-, but
I have the same problem with olders patch versions.

I would like to use my usb printer/scanner with cups and saned in
a vserver, but I need access /proc/bus/usb/* because it is
necessary for libusb.

Thank you for your answers


    .---.      Ludovic RESLINGER
   /     \
   \.@-@./     Trumpet Student in CNR
   /`\_/`\     Free Software Developer
  // )X( \\
 | \  :  )|_                   _,'|   .''`.
/`\_`>  <_/ \ @======TTT=====::_  |  : :'  :
\__/'---'\__/   ((_<=HHH___))   `.|  `. `'`
                 `---UUU---'=>         `-

Vserver mailing list

Received on Mon Oct 9 20:02:02 2006
[Next/Previous Months] [Main vserver Project Homepage] [Howto Subscribe/Unsubscribe] [Paul Sladen's vserver stuff]
Generated on Mon 09 Oct 2006 - 20:02:06 BST by hypermail 2.1.8